Login Issue Via Microsoft Azure(365) SSO login

Incident Report for Zomentum

Resolved

The issue has been resolved successfully
Posted Dec 29, 2025 - 15:59 UTC

Investigating

We are actively investigating the matter.

Temporary workaround:
We have temporarily disabled mandatory SSO from the backend. As a result, you should now be able to log in to Zomentum using your username and password.

Thank you for your patience and understanding.
Posted Dec 29, 2025 - 12:44 UTC